• Advertisement

My White Hatch

My White Hatch

Postby sekang0 » Fri Jan 25, 2013 8:03 pm

Got this car Aug 14, 2010 from a guy named Neil in Pasadena, CA. Took this pic few days after driving it back.
Image
Image
Image
Image
Image
Image
Image
Image

Bought the TE37s from AZSR5 (Jon) for it over a year before I even owned the car lol...
Image
Image

Got these shortly after....
sway bars from HASHIRIYA (Wes)
Image
Image
Image
Image

Did a shifter bushing replacement. Didn't take pics of em but they were the black delrin ones.
Image
The bushing was nonexistent....
Image

a few pics of spring and swaybar install....
Image
Image
Image
Image
Image
Image

wheel swap time!
Image
Image
Image
Image
Image


SEAT-BACK SWAP!
Image
the seats were in pretty poor shape..........
Image
Image
sprayed em with Rustoleum rust prevent and treater i think... something like that.
Image
Image
Can't leave the little details out.
Image
Image
Image


VALVE COVER SWAP!
these were just nasty wannabe ferrari red....
Image
sourced these off of ebay. Said they had Alodine coating on em. Not sure if it was legit but they looked nice with the pure metal color...
Image
Image
Image

Other random pics below are up to date i think..
Image
Image
Image
Image

THANKS FOR LOOKING >.>
Last edited by sekang0 on Sat Dec 28, 2013 9:44 pm, edited 3 times in total.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA



Re: My White Hatch

Postby Deuce Cam » Fri Jan 25, 2013 8:47 pm

Nice looking ride dude! Bummer about the break down.

Regarding the cat...you can try removing the o2 sensor to see if there's any change in performance, but you really should remove the cat to so see if it's actually clogged. A number of things can cause a clogged cat such as running really rich, oil getting in the exhaust, debris (perhaps running itbs with no filters), and so on. Hopefully others will chime in with ideas because the issue could be a number of things aside from a bad cat.
Deuce Cam
 
Posts: 1098
Joined: Sun Jan 13, 2013 3:41 pm
Location: AZ


Re: My White Hatch

Postby sekang0 » Fri Jan 25, 2013 9:13 pm

Cool man thanks! and thanks again for all the parts. Gotta get this baby smogged and re-registered...
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby Deuce Cam » Fri Jan 25, 2013 9:25 pm

No problem. Are the trd springs you have uncut? What are the spring rates?
Deuce Cam
 
Posts: 1098
Joined: Sun Jan 13, 2013 3:41 pm
Location: AZ


Re: My White Hatch

Postby sekang0 » Fri Jan 25, 2013 9:43 pm

Uncut. 8kg front 6kg rear.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby Strobelite » Sat Jan 26, 2013 2:58 am

nice ride!! I doubt I've seen your rolla around town tho, I only know about 3 ppl in stockton with a rolla.
Strobelite
 
Posts: 8
Joined: Mon Jan 14, 2013 10:58 pm


Re: My White Hatch

Postby sekang0 » Sat Jan 26, 2013 3:15 am

Thanks dude. Yea, I don't know the other rolla guys in town. If u do I'd like to meet up one of these days.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby sekang0 » Sat Jan 26, 2013 11:19 pm

Got this today. used HKS sport exhaust. Thx to Deuce Cam and so carefully packed!! Legit seller.

Image

Also got this from RidgeRacer. Wanted this NST short shift kit forever now but its always sold out. Thanks dude.

Image


Cant wait to install but gotta get the car up and running again.
Last edited by sekang0 on Thu Feb 21, 2013 7:35 pm, edited 1 time in total.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby Deuce Cam » Sun Jan 27, 2013 12:47 pm

I'm glad it arrived safely. Enjoy, I'll miss it.
Deuce Cam
 
Posts: 1098
Joined: Sun Jan 13, 2013 3:41 pm
Location: AZ


Re: My White Hatch

Postby idreamofdrifting » Wed Jan 30, 2013 6:07 pm

very nice! very very nice!
"If my Memes bother you, you're taking life way too seriously!"
~Me~

"RICE=Racing Inspired Cosmetic Enhancments"
~ga_goosh~


Image
User avatar
idreamofdrifting
Club4AG MASTER
 
Posts: 1181
Joined: Fri Jan 11, 2013 3:35 pm


Re: My White Hatch

Postby sekang0 » Wed Feb 13, 2013 6:18 pm

Installed NST short shift kit today. Damn thing shifts amazing now. Short crisp throws. Didn't take too many pics but here are the ones I did. Extended bolts are 45mm. Fits nice but the boot is a little tight now. Might cut a ring of material off the top....

Image

Image

Image

Image
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby RuizXIII » Wed Feb 13, 2013 9:18 pm

Your car is crazy clean, man. The White and TE37s are perfect.
And the fact that you have that hatch cargo cover thing...amazing haha.
irony.cc
User avatar
RuizXIII
Club4AG Enthusiast
 
Posts: 152
Joined: Wed Jan 16, 2013 8:33 pm
Location: Smell Ya Later, NJ


Re: My White Hatch

Postby sekang0 » Thu Feb 14, 2013 4:52 am

Hey thanks man. Paint needs a major redo up close tho. Thinking of stickerbombing a panel or two... I gotta take more detailed pics of everything some time.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby John H. » Thu Feb 14, 2013 5:25 pm

Car looks great! Awesome job so-far!
Did you buy that kit directly from NST or did you buy it used?
I want one! lol

P.S. :o Don't put stickers on it! Nooooooooo...
John H.
Club4AG Pro
 
Posts: 530
Joined: Thu Jan 17, 2013 10:40 am
Location: SoCal


Re: My White Hatch

Postby sekang0 » Thu Feb 14, 2013 6:54 pm

Thanks, I got it used but unused condition. I'm buying a diff fender to stickerbomb Haha. And possibly my zenki lip thats just been sitting.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby Zenki85 » Fri Feb 15, 2013 8:50 am

Great looking rolla keep her pretty!
TEAM 'CLASSIC
A 'CLASSICALIFORNIACAR
Adriansadriano@yahoo.com - email
Zenki85
Club4AG Expert
 
Posts: 318
Joined: Thu Jan 10, 2013 12:08 am


Re: My White Hatch

Postby KonaTrueno723 » Mon Feb 18, 2013 1:03 am

Nice clean hatch! Along with the nice improvements as well.. Makes me want to get a new shifter too :D
________________________________________________________________________________
Speed doesn't kill, its the sudden stop.
Toy House Automotive & Engineering
87 GTS Coupe
85 Toyota Truck V-8 Matching Trailer
72 Blown 6-71 Pro Street Vega
KonaTrueno723
Club4AG Expert
 
Posts: 434
Joined: Mon Jan 21, 2013 6:02 pm
Location: 50th Northrop-Skylab-Lockheed MD/B 6891


Re: My White Hatch

Postby fiveten » Mon Feb 18, 2013 9:09 am

I like the way you're fixing up your car, clean with legit parts. I hate how nowadays all people want to do is boro style or hellflush.
User avatar
fiveten
Club4AG Expert
 
Posts: 236
Joined: Wed Jan 09, 2013 11:21 pm
Location: So Cal 91761


Re: My White Hatch

Postby sekang0 » Tue Feb 19, 2013 5:47 am

I<3JDM. Thanks for the kind words dudes.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby Garage7RP » Tue Feb 19, 2013 9:17 am

Clean 86! Do you have a side profile picture of your car before you changed to TRD springs?
Garage7RP
Club4AG Enthusiast
 
Posts: 55
Joined: Fri Jan 11, 2013 10:58 pm
Location: Rosewood, Ca.


Re: My White Hatch

Postby RidgeRacer » Tue Feb 19, 2013 10:07 am

sekang0 wrote:Also got this from RidgeRacer. Wanted this NST short shift kit forever now but its always sold out. Thanks dude.

Image



No problem. It was a very smooth transaction with great buyer btw.

Are those 15x7 et0 TE37s?

Nice project you have going on there.
'85 Anthracite GT-S

WTB AE86 parts: Grey passenger side speaker housing and grille.
RidgeRacer
Club4AG Enthusiast
 
Posts: 57
Joined: Sun Jan 13, 2013 7:05 pm
Location: SoCal


Re: My White Hatch

Postby sekang0 » Tue Feb 19, 2013 8:41 pm

Yea those are the wheels. Real volks but the orig black decals I swapped for blue ones. I like how it looks on the bronze more. :)
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby Phoenix » Tue Feb 19, 2013 10:21 pm

damm. nice hatch!!!
Phoenix
 
Posts: 9
Joined: Thu Jan 10, 2013 2:16 am
Location: Long Beach


Re: My White Hatch

Postby sekang0 » Wed Feb 20, 2013 3:34 am

Garage7RP wrote:Clean 86! Do you have a side profile picture of your car before you changed to TRD springs?


Nah sorry dude. The very first pic is how I bought it with intrax progressive springs.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby sekang0 » Thu Feb 21, 2013 4:01 pm

Still trying to find out why its not passing SMOG.

Cleaned EGR system today. Wasn't too bad. EGR bladder works fine and so did the vac modulator but replaced it just because the cap was loose and inside was black... not sure if its supposed to be.

Image

Image

Replaced TPS also just because I suspect its bad. Killed 2 catalytic converters so far. Shouldn't just throw parts at the car but new is better. :lol:

Image

Also, while I was out there workin on the car. THIS CAME IN.

Image

Image

Image

Gonna turn my Cusco strut bar into a tri-bar soon... :!:
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby hachidustin » Thu Feb 21, 2013 6:02 pm

I love seeing clean 86's. I especially love white as a color choice! And anything HKS for the 86 is pure gold, enjoy the car man!
I have a beard, therefore...F@%& YOU!
hachidustin
Club4AG Regular
 
Posts: 38
Joined: Wed Jan 23, 2013 11:40 am
Location: Green Cove Springs, FL


Re: My White Hatch

Postby sekang0 » Thu Feb 21, 2013 10:53 pm

Thanks. The paint could use some help, and leaks a bit, and noisy R&P, but other than that its unmolested. :)
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Re: My White Hatch

Postby Strobelite » Fri Feb 22, 2013 2:05 am

Hmm , I didn't passed smog in my 86 until i changed the CAT after the second try, well that was after i did a tune up, changed the spark plug wire set, spark plugs, new oil, and seafoam and a new O2. on the first try ,it was boreder line close to passing. timing perhaps ?
Strobelite
 
Posts: 8
Joined: Mon Jan 14, 2013 10:58 pm


Re: My White Hatch

Postby Zenki85 » Fri Feb 22, 2013 8:58 am

Oh man that nst short shifter. I wanted to pick that up! Must be nice!
You are doing a great job building up the corolla.
Question did you just hook up the tps? I have a extra one but I haven't put it in yet
TEAM 'CLASSIC
A 'CLASSICALIFORNIACAR
Adriansadriano@yahoo.com - email
Zenki85
Club4AG Expert
 
Posts: 318
Joined: Thu Jan 10, 2013 12:08 am


Re: My White Hatch

Postby sekang0 » Fri Feb 22, 2013 10:43 am

Strobelite wrote:Hmm , I didn't passed smog in my 86 until i changed the CAT after the second try, well that was after i did a tune up, changed the spark plug wire set, spark plugs, new oil, and seafoam and a new O2. on the first try ,it was boreder line close to passing. timing perhaps ?


Maybe I should seafoam too. Everything else you listed is new on mine too. But my stock exhaust mani was really loose on the downpipe last time. I just tightened it up as best I could but I might have to take it off the car to get it super tight.
'85 GT-S project since 2010
Image
sekang0
Club4AG Expert
 
Posts: 227
Joined: Fri Jan 11, 2013 8:46 pm
Location: Stockton, CA


Next

Return to OWNERS and BUILDERS

Who is online

Users browsing this forum: No registered users and 2 guests