AE86 85 GTS COUPE ZENKI ISSUES

Swooki
Club4AG Enthusiast
Posts: 115
Joined: Wed Dec 21, 2016 1:48 pm

AE86 85 GTS COUPE ZENKI ISSUES

Postby Swooki » Mon Nov 15, 2021 11:23 am

Hi all,
I recently acquired a 85 GTS Coupe and I have some issues with it.

1) Brake light and Battery light is on dash but Alternator is working. I connected the brake lid plug to harness and it still persist. I am not sure what it could be (the car is swapped from an MR2)

2) when I give it throttle, it kind of torques twice like you feel it go and it goes again real quick like a lag. So imagine when you press gas, a normal car will accelerate but mine would accelerate and accelerate again really fast so like a delay (twice) I am not sure what it could be? like instead of "go" it'll be "go - go" then it'll accelerate.

3) Takes a lot of cranks for the car to start. Sometimes, it'll start and die real quick having a hard time grabbing.
I swapped battery already. Once car is started, it works perfectly and if you turn it on again, it'll start right away. It's only cold start that's an issue.

davew7
Club4AG Expert
Posts: 221
Joined: Fri Jun 06, 2014 4:34 am
Location: Michigan

Re: AE86 85 GTS COUPE ZENKI ISSUES

Postby davew7 » Tue Nov 16, 2021 3:59 am

!] You probably have bad ground(s) for those two circuits if, as you say, every thing else has checked out.
2] Try adjusting the TPS per the manual, could also be low fuel pressure. Should be about 38 PSI.
3] Check the cold start injector. Pull it out of the manifold and verify that it is spraying fuel at start up. Hope it's not the cold start sensor $$$.
Dave W

Swooki
Club4AG Enthusiast
Posts: 115
Joined: Wed Dec 21, 2016 1:48 pm

Re: AE86 85 GTS COUPE ZENKI ISSUES

Postby Swooki » Sun Mar 13, 2022 11:16 am

davew7 wrote:!] You probably have bad ground(s) for those two circuits if, as you say, every thing else has checked out.
2] Try adjusting the TPS per the manual, could also be low fuel pressure. Should be about 38 PSI.
3] Check the cold start injector. Pull it out of the manifold and verify that it is spraying fuel at start up. Hope it's not the cold start sensor $$$.
Dave W



1) where are the grounds located?

2) Okay.. Do you have the manual? and how can i check fuel pressure?

3) I swapped the cold start injector on manifold with a new one

How much is the sensor and where can i get one

davew7
Club4AG Expert
Posts: 221
Joined: Fri Jun 06, 2014 4:34 am
Location: Michigan

Re: AE86 85 GTS COUPE ZENKI ISSUES

Postby davew7 » Tue Mar 15, 2022 6:20 am

1) where are the grounds located? The ground is located on the intake manifold. 4 brown wires on an eyelet. Also several [three] sensor grounds are combimed into one, in the harness and are all crimped together. I've seen high resistance at the crimp joint. So if cleaning the ground does not work you may have to look inside the harness.

2) Okay.. Do you have the manual? and how can i check fuel pressure? Any pressure gauge above 40 psi will work. the easiest place to check pressure is at the connection right before the fuel filter.

3) I swapped the cold start injector on manifold with a new one

How much is the sensor and where can i get one. The last time I checked Rock Auto had the sensor for a $100, but do number 1) and 2) before replacing the sensor.
dave7

Swooki
Club4AG Enthusiast
Posts: 115
Joined: Wed Dec 21, 2016 1:48 pm

Re: AE86 85 GTS COUPE ZENKI ISSUES

Postby Swooki » Fri Mar 18, 2022 1:44 pm

davew7 wrote:1) where are the grounds located? The ground is located on the intake manifold. 4 brown wires on an eyelet. Also several [three] sensor grounds are combimed into one, in the harness and are all crimped together. I've seen high resistance at the crimp joint. So if cleaning the ground does not work you may have to look inside the harness.

2) Okay.. Do you have the manual? and how can i check fuel pressure? Any pressure gauge above 40 psi will work. the easiest place to check pressure is at the connection right before the fuel filter.

3) I swapped the cold start injector on manifold with a new one

How much is the sensor and where can i get one. The last time I checked Rock Auto had the sensor for a $100, but do number 1) and 2) before replacing the sensor.
dave7


1)
Can you send pics of where the grounds are?
I am kind of confused. I see one on intake manifold that goes to firewall
I see one that goes to the frame rail on header side connected to block

the rest i don't see like the eyelet ones and other ones you said. Can you take photos?

2) so connect top and bottom those 2 of filter?

3) I swapped this, is this it? https://puu.sh/IPw36/f6f569b2a8.jpg
or is it this? https://puu.sh/IPw45/65c515c129.jpg